Drupal 8 and PHP 7

Submitted by dryer on Thu, 11/12/2015 - 19:05
PHP 7 mug

Drupal 8 is launching soon and so is PHP 7. It's worth noting that Drupal 8 does not officially support PHP 7 at launch date, so even if you were craving for the performance boost - it's better to wait until everything in Drupal 8 is tested and proved to be PHP 7 compatible.

For PHP 7 support in Drupal 7, the plan is to backport the compatibility at a later date, as the ticket is labeled as "needs backport to D7".

 You can follow the progress of the Drupal 8 compatibility work over on the Drupal issue queue:

So while it's not great that it slipped, it's fantastic that we caught that issue before release rather than afterwards, and that we should have Drupal 8.0.0 and PHP 7.0.0 100% compatible (at least to the extent of our test suite).

Update: While Drupal 8 now supports PHP 7, it seems that Drupal 7 has superior performance to Drupal 8 - even with PHP 7.

Source: [META] Support PHP 7